BCC Particle Illusion

BCC Particles

Overview

Introduced with Continuum 2019 BCC, Particle Illusion is a 2D, sprite (image) based particle effect system that is preset driven, easy to use, and powerful. A 64-bit update of the original particleIllusion from the early 2000’s, a new UI, reorganized libraries, and thousands of curated presets bring exciting particle effects to artists and editors of any skill level. The addition of Mocha tracking, masking, and transfer modes makes integrating advanced particle effects into your work easier than ever.

 Important: There is a single “Sampler” library installed with Particle Illusion. To get the full set of additional emitter libraries use the “Download Emitters” option from the “Help” menu:

BCCPIDLEmitters

A Brief Primer on Particle Effects

If you’ve not used particle effects before, or if you’re new to Particle Illusion — often referred to as “PI” in these docs — a quick look at the terminology will be helpful in understanding the rest of the documentation and tutorials.

Particles: Particles are the visible entities in Particle Illusion. You have no direct control over individual particles; once they are “born” they behave based on the values set in their Particle Type. Particles use images for their appearance.

Particle Type: A particle type is the collection of properties that determine how particles of this type look and behave. A particle type consists of an image (or images), a color gradient, and various properties such as velocity, size, weight, etc.

Emitters: An emitter is not visible, but is the object that creates particles. Emitters come in 4 shapes types: point, line, ellipse (circle), and area. An emitter contains one or more particle types, and “global” duplicates of many of the particle type properties (velocity, size, etc.). Emitters, unlike particles, can be directly controlled and moved over time.

So an emitter is made up of particle types, and particle types are made from images, and particles are created by the emitter based on the properties of its particle types. In other words, an emitter creates particles which combine to form the visual effect.

A more complex type of emitter is a “super emitter”.

Super Emitters: This is a special type of emitter in Particle Illusion that does not create particles directly, but creates other emitters which in turn create the particles.

Free Emitters: The emitters that a super emitter creates. They are similar to particles in that you cannot directly control their position — once they are “born” they behave based on the properties of their Free Emitter Type.

Free Emitter Type: Like a Particle Type, this is the collection of properties that determine how the free emitters of this type will behave.

So a super emitter is made up of free emitter types and free emitters are created by the super emitter based on the properties of its free emitter type. Each free emitter type consists of particle types, and particles are created by each free emitter based on the properties of its particle type. In other words, a super emitter creates free emitters, which in turn create particles which combine to form the visual effect.

Emitter Library: a collection of emitter “presets” saved as a single file. This is not really important in Particle Illusion unless you want to copy or move libraries — to share them as an example. Note that once an emitter is added to a project it is completely independent of that library.

These Emitter Library emitters are the starting point for building new particle effects: the first step in building an animation is to add one or more emitters from the Emitter Library to your project.

Navigating the Particle Illusion User Interface

Overview

In this section we will introduce the five primary windows used in Particle Illusion to select, modify, animate, and preview effects.

The Particle Illusion UI at a glance

  1. Emitter Library Browser
    The Emitter Library browser displays every emitter library and emitter available. Manually browse the thousands of available emitters or use the emitter search to help you zero in on the effect you’re looking for.
  2. Emitter Preview
    A live window that displays the emitter selected in the Emitter Library Browser. Click and drag in this window to see how the selected effect will behave before adding it to your project.
  3. Composite View (or “Stage”)
    The Composite window displays the composited effect as it will appear in your final output. Click to add the selected library emitter to the project, then adjust the emitter position by dragging if needed. It also offers menu options that adjust some preview settings while you work, such as zoom level, background image preview, and H.U.D. (onscreen overlays). Also known as the “Stage” if you’re an original particleIllusion user.
  4. Controls View
    The Controls view displays the properties and animatable parameters for each emitter. The Controls view allows you to adjust the values for each parameter and choose how to interpolate those values between keyframes. This is also where you can create new layers, to better organize a project that contains multiple emitters.
  5. Graph View
    The graph view gives you a wide range of controls that allow you to animate parameter attributes in the timeline by setting keyframes. A keyframe sets specific parameter values for a parameter at a certain point on the timeline. When you place multiple keyframes on the timeline, PI interpolates, or computes intermediate values, between keyframe values to animate the effect. Keyframes will be covered in detail in a future tutorial.

Adding An Emitter: The Basics

  1. Select an emitter. Either browse the libraries or use the emitter search to find the type of particle emitter that you’ll want to use in your project. If you can’t find exactly what you’re looking for, select something that is close, as you’ll be able to modify at least some aspects of it later.
  2. Click in the Composite View — this will add the emitter. Alternately you can double-click the emitter name in the library browser to add it to the exact center of the Composite View.
  3. Adjust parameters. In the Controls View select the appropriate parameter and adjust its value as needed. Experimenting is encouraged. Note that if you want to make the entire effect bigger, use the “Zoom” parameter instead of “Size”.
  4. Animate position (optional). To animate position, click the “Animate/Static” button (which looks like a big key) so it turns red, jump ahead in time, then drag the emitter position in the Composite View. Note that the position X/Y values in the Controls View are drawn with a red box — this indicates they are animated.
  5. Click “Apply” to close and return to the host application.

 

That’s all that is required to add a Particle Illusion effect!

 

 

Adding An Emitter: Parameters

Before looking at the parameters in the Controls View, remember from earlier that a regular emitter is made up of one or more particle types, and a super emitter is made up of one or more free emitter types, which in turn contain one or more particle types. In the Controls View these are displayed as a hierarchy, with the emitter parameters at the top level, the free emitter type parameters at the middle level (for super emitters), and the particle type parameters at the lowest level. Since many of the parameters at each level have the same names — for instance you’ll see “Velocity” at the emitter level, free emitter type level, and particle type level — it’s important to know the difference between them.

As an example, you may see that the emitter (top-level) “Spin” value is 100, but the particles are not spinning. If you realize that the emitter level parameters are scale factors, you’ll know that you also need to check the particle type (lowest level) “Spin” value, which is probably set to 0. In order to see spin, the “Spin” values at all levels must be non-zero.

Now let’s take a closer look at the parameters in the Controls View:

We’ll skip the “Properties” group for now.

Controls View Position XY

Controls View

“Position XY” is the emitter position, which can be controlled here or in the Composite View directly.

The parameters just below the “Position” parameters can be thought of as scaling factors, applied to all similarly-named parameters below them in the hierarchy. Most of these should all be self-explanatory: “Size” controls the size of the particles, “Velocity” how fast they move, etc.

“Motion Rand.” is Motion Randomness.

“Tint Strength” controls the amount of tint color applied, and is used in conjunction with the Tint Color (see below). A value of 100 will completely override the particle colors, while when set to 0 the Tint Color has no effect.
“Emission Angle” and “Emission Range” go together — when “Emission Range” is less than 360 degrees, the “Emission Angle” becomes useful.

Note that “Angle” is used to rotate line, area, and ellipse emitters, and will probably have no visible effect on point or circle emitters.

Emitter Properties

Going back to the “Properties” group now, you’ll see controls for preload, emitter shape, and more:

Controls View Properties

Controls View

“Shape” allows you to switch between “Point”, “Line”, “Area” (rectangle),  “Ellipse”, and “Circle”. Note that additional parameters will be visible for some of these shapes, and will be covered in more detail later.

“Frames to Preload” sets the number of frames that the emitter will run before its first frame in the project, allowing it to have many particles visible at the start instead of starting from zero particles. Library emitters that take a while for their effects to evolve will usually have “Frames to Preload” set to a non-zero value.

“Particle Order” determines if the particles will be drawn in order: oldest first, oldest last, or unordered. Unless the specific effect requires particles to be drawn in order, it’s best to set this to “Unordered”. Some types of effects that might require particles to be drawn in order are heavy smoke trails, geometric effects, and effects that are animated to grow/shrink over time (as if the emitter were coming toward or moving away from you). Note that particles flagged as “intense” always combine in a way that makes “in order” drawing inapplicable. (“Intense” particles will be covered in the “particle type” section below).

“Tint Color” is a way to colorize an emitter — change its overall color without editing the individual particle type color gradients. It’s used in conjunction with the “Tint Strength” parameter and can be a quick way to adjust colors of complex emitters or help an effect blend into a shot.

The emitter will have at least one more level of parameters below these top-level parameters, depending on the number of particle types it has, or if it is a super emitter, the number of free emitter types it has. In this example, the emitter is a regular (non-super) emitter with a single particle type named “trails”:

Emitter Properties Trail

Trail

It has many of the same parameters as seen above, with some subtle differences. (As before we’ll skip the “Properties” group initially)

First, the “Weight” and “Spin” parameters can go negative here. Particles with negative weight will rise, and particles with negative spin will rotate in the opposite direction.

There are also “Variation” parameters here that can be used to produce a range of values. In this example the “Size” is 10.0 and the “Size Variation” is 7.0, which means that particles will be created with a size that is anywhere from 6.5 to 13.5.

One thing to note: the values for size, velocity, etc. are relative and without units. So a “size” value of 10 does not mean 10 pixels; the only thing you can say for certain is that a particle with a size of “10” is twice as big as a particle with a size of “5”. Similarly, a “Life” value of 6 does not mean 6 frames or 6 seconds.

The “Over Life” parameters — “Size Over Life” for instance — control the parameter over the life of the particle. They’re a bit different than normal parameters, so let’s take a look at them in more detail.

Normal Parameters vs. “Over Life” Parameters

The normal parameters like “Size” and “Velocity” designate the values that will be used at the instant the particle is created. Even if these parameters are animated (change over time) this is still true. So if the “Velocity” parameter for instance starts at 0 for several frames before increasing, the particles created when velocity was 0 will not move even when the velocity value has increased.

To change the particle velocity over time you use the “Velocity Over Life” parameter. When this or any “Over Life” parameter is selected, the Graph View changes:

Graph View Size Over Life

Size Over Life

For “Over Life” parameters the horizontal scale of the Graph View no longer shows frame numbers, but instead displays the percentage of the particle’s life. On the left is 0.0, the birth of the particle, and on the far right 1.0, the particle’s death. In the example above for “Size Over Life” you can see that the particle starts large, slowly decreases in size until about 70% (0.7) of its life has passed, then more quickly decreases until it ends its life with a size of 0.

Note that this is independent of how long the particle actually lives; whether it is alive for 10 frames or 500 its size will follow this graph over its life.

Parameters that are selected in the Controls View have their animation displayed in the Graph View:

Graph View of Selected Parameter

Selected Parameter Seen in Graph View

Using the graph view you can change the values of data keys, reposition them, delete keys, or create new ones.

Values that are animated will be outlined in red, and the arrows to the right of the value are used to move between the keyframes. The interpolation type for the key is shown between the arrows, and is changed using the menu that displays when clicked:

Interpolation Type

Interpolation Type

To delete a key, select it in the graph window, then press your keyboard’s “delete” key.

Particle Type Properties

The “Properties” group contains most of the low-level controls for particle types: how the particle is drawn, its color, and more:

Particle Type Properties

Particle Type Properties

The “Flip” option determines if the sprite (image) used for the particle is flipped horizontally, vertically, or both.

The “Intense” option makes the particle additive, giving it an “intense” look (hot, bright, glowing, etc.) When checked, the “Preserve Color” option is available, which will help to keep “intense” particles from adding to white, preserving some of their original color.

“Single Particle”: when checked, a single particle of this type will be created. It will be connected to the emitter’s position (velocity and motion randomness will be ignored), and its life will be very long (on the order of 10K frames).

“Attached to Emitter” can be used when you want particles to move with the emitter, but don’t want just a single particle. When “Attached to Emitter” is checked, the attachment amount parameter becomes available — a value of 0 means that the particles won’t move with the emitter, and a value of 100 means that they fully move with the emitter.

There are three subgroups of particle type properties: “Behavior”, “Color”, and “Alpha”.

Particle Type Behavior

Particle Type Behavior

The “Behavior” group lets you set the particle angle. You can specify the angle (in degrees) and all particles of this type will be created at the same angle, you can select a “Random” angle, where you specify the angle range and offset value, or you can have the particles “Align to Motion”.

Particle Align to Motion

Particle Align to Motion

When aligned to motion you specify the rotation angle, and the particles will align themselves with their initial motion. If the particles have no initial velocity this may not work as expected.

When the “Keep Aligned to Motion” option is checked the particle angle will continuously update based upon the particle’s motion, changing as the particle falls due to gravity. Note that when this option is checked, the particle spin parameter will be ignored — “Keep Aligned to Motion” overrides the spin value.

The final parameter in the “Behavior” subgroup is “Use Emitter emission”. When checked, this particle type uses the emitter “Emission Angle” and “Emission Range” parameters. If unchecked, you’ll see “Emission Angle” and “Emission Range” parameters added at the particle type level. It’s not common to see this option unchecked.

The next two subgroups, “Color” and “Alpha”, work together to determine the particle colors and transparency.

Color Gradient

Color Gradient

Clicking the color gradient brings up the gradient editor.

The “Color Type” menu allows you to select between:

  • “Full Gradient”: the gradient represents the life of the particle, where the color at the left edge of the gradient is the color when the particle is born, and the right edge is the color when the particle dies. When this option is selected you have a “Repeat” value that can be used to repeat the gradient over the life of the particle.
  • “Random Gradient”: a random color from anywhere on the gradient is chosen for the particle at its birth. The particle color does not change over its life. Choosing this option reveals a “Use key colors only” option, when checked the defined gradient colors are the only possible random choices.
  • “Next key color”: A specified number X of particles of each defined gradient color are created, then the next gradient color is used for the next X particles, and so on. The number of particles created at each color must be specified.
  • “Color from layer”: each particle gets its birth color from the source pixel beneath its creation position. The “Update Color from Layer” option means that the particle resamples the source image as it moves.

The alpha gradient shows the particle alpha over its life, and clicking the alpha gradient opens the alpha editor.

Alpha Gradient

Alpha Gradient

The “Alpha Type” menu allows you to select between:

  • “Link To Color”: when selected the particle color gradient is converted to alpha values.
  • “Alpha From layer”: each particle gets its birth alpha from the source pixel beneath its creation position. The “Update Alpha from Layer” option means that the particle resamples the source image as it moves.
  • “Full Gradient”: the gradient represents the life of the particle, where the alpha at the left edge is the alpha when the particle is born, and right edge indicates the alpha when the particle dies. Note that white is fully opaque, and black is fully transparent. When this option is selected you have a “Repeat” value that can be used to repeat the gradient over the life of the particle.

Emitter Shapes

In the emitter properties group you can select different “shapes” for the emitter, and depending on the shape chosen there are additional parameters that are revealed. The options are “Point”, “Line”, “Ellipse”, “Area” and “Circle”.

For “Point” emitters, the particles all emanate from a single point. This is the simplest shape for an emitter, and there are no additional parameters for it.

With “Line” emitters, the particles all emanate from a line or series of connected line segments. After switching the shape to “Line” you will see a line (if the HUD is enabled) from the emitter point to the mouse position. Clicking adds a new line point — double-click or press the ESC key to end the line. Line emitters have the following additional parameters:

  • Emission In: particles will be emitted from one side of the line. Note that only when Emission Range is set below 360 degrees will you see this, and it will be most clear when the Emission Range is below 180 degrees.
  • Emission Out: particles will be emitted from the other side of the line.
  • Emit at Points: When checked the “Number Points” parameter becomes visible. Use this option to create a row of point emitters evenly spaced along the line (or line segments).

Note that on Mac Cmd-click will delete a line emitter point, and Option-click will allow you to add points to the line. On Windows Ctrl-click to delete a line point, and Alt-click to add them.

Set to “Ellipse”, the particles will be created along the ellipse. As with “Line” emitters, these additional parameters are available:

  • Emission In: particles will be emitted toward the inside of the ellipse. Note that only when Emission Range is set below 360 degrees will you see this, and it will be most clear when the Emission Range is below 180 degrees.
  • Emission Out: particles will be emitted toward the outside of the ellipse.
  • Emit at Points: When checked the “Number Points” parameter becomes visible. Use this option to create evenly spaced point emitters along the ellipse.

In addition, “Ellipse” emitters have “X Radius” and “Y Radius” parameters which can be used to resize the ellipse.

Unlike the other shapes, “Area” emitters create particles throughout a rectangular area (not just along the outline). Area emitters add:

  • Emit at Points: When checked the “Num Points X” and “Num Points Y” controls are revealed, allowing you to create a grid of point emitters.
  • “Width” and “Height” parameters to control the dimensions of the rectangle.

A “Circle” emitter is a special case of “Ellipse”, in that only a single “Radius” parameter is added instead of “Radius X” and “Radius Y” — all other parameters for “Circle” emitters are the same as for “Ellipse” emitters.

One important note about emitter shapes other than “Point”: Line, Ellipse, Circle, and Area emitters emit more particles the “bigger” the shape. For instance, a long line emitter will create many more particles than a short line emitter, a circle emitter with a large radius will create many more particles than a small radius, etc. The most extreme case of this is probably the “Area” emitters — increasing the width and height of an area emitter so it fills the entire frame will most likely create many more particles than you intended, with the result of this being poor performance and greatly reduced responsiveness.

For this reason it’s a good idea to reduce the “Number” value significantly before increasing the dimensions (line length, radius, width and/or height) of any shaped emitter, then increase it again slightly afterward if necessary. This will ensure that performance and responsiveness stays optimal.

Super Emitters

Remember that a “super emitter” is a special type of emitter in Particle Illusion that does not create particles directly, but creates other emitters (free emitters) which in turn create the particles.

In the Controls View, this extra complexity is displayed as an extra level in the emitter’s hierarchy:

Controls View Super Emitters

Controls View Super Emitters

The “f-” parameters such as “f-Life”, “f-Number”, “f-Velocity”, etc. are applied to the free emitters themselves and do not control particles.

For example, to create more free emitters, increase the “f-Number” value. To make the free emitters move faster, it is “f-Velocity” that must be adjusted.

You’ll notice that there is no “f-Size” parameter. This is because free emitters are not visible, and therefore do not need a “size” control.

Similar to the parameters for particle types which were discussed earlier, there are also “Variation” and “Over Life” controls for the “f-” parameters.

Below the “Over Life” params (specifically after “f-Zoom Over Life”) you will see what looks like the same set of parameters that were visible at both the emitter and particle type levels: “Life”, “Number”, “Size”, etc. These are the scale factors for the corresponding controls in all of the particle types that this Free Emitter Type contains — they control the particles.

This means that for a Super Emitter there are two different levels of scale factors that are applied to the particle type parameters.

This may seem overly complex and a bit difficult to grasp when reading it, and when you’re looking at an emitter that contains only a single particle type, it may be overkill. The advantage of this system of a hierarchy of controls becomes apparent when dealing with emitters that have several different particle types.

Animating  Parameters

Any parameter that can be animated — by manually creating keys to change values over time — displays the keyframe controls to the right of the parameter value in the Controls View:

Animating Parameters

Animating Parameters

Note that any parameter that is animated (contains more than one key value) has its value outlined by a red rectangle. The left and right arrows are the key navigation buttons, and clicking them jumps the current time indicator (CTI) to the frame of the appropriate key.

The interpolation control is between the two key navigation buttons, and is used to switch the interpolation type of the current key. Note that if the CTI is not at a keyframe, the interpolation type will not display (will show as an empty box).

Interpolation Type Choices

Interpolation Type Choices

Linear: The value changes at this key occur linearly, along a straight line.

Bezier: The value changes along a smooth curve that is adjusted in the Graph View using the control point “handles”.

Constant: Setting a “constant” value removes all keys from this parameter.

To adjust keys in the Graph View, you can just click and drag them. You can also change the parameter value itself in the Controls View. If the CTI is at a keyframe when you change that value, that key will be adjusted. If the CTI is not already at a keyframe and the graph already contains a key, a new key will be created. (If you adjust the value for a “Constant” parameter, the value will change but no key will be created.) More in the “Working with Data Keys” section below.

There is another way to create keys to animate a parameter: using the animation controls. These are found just under the mini-timeline, above the Graph View on the left:

Key Navigation Controls

Key Navigation Controls

The buttons with the left and right arrows are key navigation controls, and they have the same effect as the buttons to the right of the parameter value in the Controls View: they move the CTI to the next or previous data key (if they exist).

The button with the “+” sign adds a key at the current frame for the current parameter. Note that this works even when the parameter interpolation is set to “Constant”.

The larger key button is a toggle; when turned on any parameter changes will create keys. Since there are other ways of creating keys for most parameters, this may not be a button you’ll use often… with one exception: this button is the only way to animate the position of an emitter.

Animating Emitter Position

Although each emitter has a “Position XY” parameter in the Controls View, selecting that parameter — unlike with all of the other parameters that can be animated — does not display anything in the Graph View.

This is because position changes, for animation or not, must be made in the Stage by clicking and dragging the emitter.

To animate the emitter position:

  1. Click on the emitter in the Stage and drag it to its starting position.
  2. Toggle the “Animate” button on.
  3. Jump the current time indicator (CTI) forward some number of frames
  4. Drag the emitter in the Stage. You should see the emitter motion path in the Stage now:

 

Animate Emitter Position

Animate Emitter Position

You can now continue moving the CTI and dragging the emitter to create new position keys as needed.

To create position keys that are between two existing keys, just move the CTI between those keys and drag the emitter — a new key is created regardless of the stage of the Animate button.

Note that you can click and drag position keys directly in the Stage, similar to the way that you can do this in the Graph View for other parameters.

To change a position key from “Linear” to “Bezier”, use the interpolation control to the right of the Position XY values in the Controls View — just as you would for any other parameter.

Working with Data Keys

We mentioned already that it’s possible to click and drag a data key in the Graph View, and that you can change a data key’s value using the Controls View. There are a few other features that make working with data keys easier:

  • Multi-selecting data keys. You can shift-click on keys in the graph view to select multiples, or click and drag to create a selection rectangle that will select multiple keys. All selected keys can be dragged as a group.
  • Deleting data keys. Use your keyboard “delete” key to delete all selected keys.

When a data key is set to “Bezier” interpolation, you can drag the control handles to change the curve. In addition, you can:

  • On Mac: Option-drag a bezier handle disconnects the two handles and lets them move independently. Option-drag on one of the disconnected handles to reconnect them.
  • On Windows: Alt-drag a bezier handle disconnects the two handles and lets them move independently. Alt-drag on one of the disconnected handles to reconnect them.

Using the Playback Controls

The playback controls appear above the Graph View and below the Stage:

Playback Controls

Playback Controls

These allow you to toggle playback, move one frame forward/back, move 10 frames forward/back, or jump to the start frame (frame 0) or end frame. The spacebar is a keyboard shortcut for the play button.

There is also a “looping” control at the far right that should be self-explanatory.

The area just above the playback buttons — where the blue frame indicator line shows — is called the “Mini Timeline”. You can click anywhere in the Mini Timeline to jump the current time indicator (CTI) to that frame. This is also where keys are shown for the selected parameter — if you want to change the position of any keyframes you can do that in the Mini Timeline. Doing it here removes the risk that you might unintentionally change a key’s value when trying to move it in the Graph View.

Just above the Mini Timeline are the trim controls for setting the In and Out points. Drag them to set the playback range, or double-click between them to clear both of them and reset to the full play range.

Emitter Libraries

Particle Illusion is preset driven, and there are well over 2500 particle emitters in the various emitter libraries. Only a single “Sampler” library is installed with Particle Illusion, but to get the additional libraries use the link provided in the “Help” menu:

Download Emitters

Download Emitters

You’ll need to restart Particle Illusion after installing those libraries to make them available.

The concept of libraries is not so important in Particle Illusion at this time, since it is not possible to create new libraries or modify the libraries. (These features are planned for a future release.) The important thing to know is that the emitters have been grouped into themed libraries, so that most smoke emitters are in the “Smoke” library, explosions are in “Explosions”, etc.

This is only important if you’re manually browsing the libraries, but with so many emitters to look at the only realistic way to browse is to first use the emitter search function.

The search is fairly basic at this time, but still can really help you reduce the number of emitters that you need to browse. Note that at this time search works only on emitter and folder names, so a search may not return every emitter that fits a specific search term. Also, try to think of synonyms when searching. For instance, if you want to find “Sparkle” type emitters, you might also search on the terms “pixie”, “fairy”, and “magic”. To find explosions, also search on “burst”,  “firework”, or “boom”. (Some emitters have names that are more creative and less descriptive.)

Note that if you used (or are still using) the legacy version of particleIllusion 3.0 and created emitter libraries with it, those libraries can still be used in Particle Illusion. There is no “Load Library” command, so in order for Particle Illusion to find your emitter libraries you’ll need to copy them to a specific location:

On Mac:

/Library/Application Support/BorisFX/EmitterLibraries

On Windows:

C:\ProgramData\BorisFX\EmitterLibraries

The more emitter libraries that are in those folders, the longer PI will take to load all of them, so you may want to be selective when you’re adding emitter libraries to that folder.

Motion Tracking and Masking

When Particle Illusion is used as a plugin, motion tracking and masking are available, powered by Continuum’s integrated Mocha tracker.

With this tracking you can essentially “pin” an emitter to a feature in your shot — for instance a train’s smokestack — moving it automatically without requiring you to manually animate the emitter position.

To track the position of an emitter, select “Emitter” for the Transforms parameter:

Track Position of Emitter

Track Position of Emitter

 

 

 

 

 

Then expand the “Motion Tracker / Mocha” group and click the “Mocha Motion Tracker” button:

Mocha Motion Tracker

Mocha Motion Tracker

 

 

 

 

 

This opens the Mocha interface, where you can then track the emitter position:

Track Emitter Position

Track Emitter Position

The details of how to use Mocha are provided elsewhere, but the key concept to understand when using it with Particle Illusion is that the “Transforms” parameter must be set correctly:

  • “Emitter” if you want to track an emitter position in a shot with a stationary camera
  • “World” if you want to track the camera movement only (with emitters that don’t move or that you’ll animate manually)
  • “World + Emitter” if you want to track both camera movement and emitter position

Mocha not only provides tracking, but also masking via the PixelChooser. When in the Mocha interface, there are several ways to draw masks: freehand, as X-splines, with the magnetic tool, and more.

Once the masks are drawn, they also get tracked by Mocha, reducing or eliminating any manual repositioning. There are parameters for feathering, inverting the mask, and more:

Mask Parameters

Mask Parameters

 

Both the Mocha tracking and masking are essential features to integrate Particle Illusion effects into your projects.

 

 

Composite Style / Apply Modes

Also when used as a plugin, Particle Illusion can be applied using a variety of transfer modes. The default setting is “Direct (Classic)”, which composites the particles directly over the source layer — this is the method used by the legacy particleIllusion application.

Transfer Modes

Transfer Modes

 

 

 

 

Although this “Direct” composite style may be ideal for some projects, a wide variety of apply modes become available once the “Alpha + Apply Mode” Composite Style is selected:

Alpha plus Apply Mode

Alpha plus Apply Mode

 

With an apply mode selected, you then have the ability to not only mix the selected mode with Normal mode using the “Apply Mix” value, but you can adjust the Opacity of the effect too — both of these give you a huge amount of control in blending the particle effects into your project.

 

 

 

 

 

 

Standalone vs Plugin Mode

Although you’ll typically use Particle Illusion as a plugin applied to a layer in your host, it’s also possible to launch it as a standalone application. When in standalone mode you’ll be able to modify the Project Settings, but will not be able to render (save rendered output).

Project Settings

The Project Settings Window allows for customization of the current project: Stage size, Duration, Frame Rate and other features. (When PI is launched from a host such as Adobe After Effects, many of these parameters are pulled directly from the host itself, and cannot be changed).

Project Settings

Project Settings

Motion Blur is a key feature that adds realism to many of the emitters, and when turned on in a project (using the “Enable” checkbox here or the “Stage – Motion Blur” menu) these are the settings used. You probably won’t want to change these values, but this is what they do:

  • Extra Frames. This sets the number of frames of motion blur to use. Note that motion blur requires multiple copies of each particle to be drawn, so although higher values result in smoother blurring, it takes longer to render. The default value of “4” is a good compromise between quality and performance.
  • Blur Amount. The amount of the distance between frames that the blurring occurs. When set to 100% the particles are blurred the entire distance they would move between the two frames. When set to 50%, the blurring will occur in ½ the distance. (When set to 0% no blurring occurs.)

Intensity Adj. This is used to adjust the opacity of “intense” particles. In some emitters using motion blur may make the “intense” particles less visible — this slider can be used to compensate. Similarly, there may be times when you’d want to use this slider to reduce the visibility of these particles. Note that you will rarely, if ever, have a need to change this setting.

The Preferences Pane

The Preferences Panel is where you set the default project settings: Stage Size (resolution), Pixel Aspect ratio, Duration, etc.:

Preferences

Preferences

It’s important to realize that changing the Stage Size here does NOT change the current project — it only applies when a new project is created.

The “Click in Stage to Add Emitter” option can be unchecked if you find yourself accidentally adding new emitters to the Stage by clicking. Note that if you uncheck this option, the only way to add an emitter to the project will be to double-click its name in the Emitter Library Browser.


Category:

BCC Particles

BCC Color & Tone

BCC Perspective

BCC Perspective

BCC Licensing

BCC Licensing

BCC Obsolete

BCC Key & Blend

BCC Obsolete

Nested Subgroup

BCC Art Looks

BCC Time

Nested Subgroup

BCC Image Restoration

BCC Transitions

BCC Blur & Sharpen

BCC Transitions

BCC Obsolete

BCC Textures

BCC Color & Tone

BCC Image Restoration

BCC Warp

BCC Art Looks

BCC Transitions

BCC Art Looks

BCC Art Looks

BCC Textures

BCC Art Looks

BCC Transitions

BCC Key & Blend

BCC Key & Blend

BCC Textures

BCC Textures

BCC Color & Tone

BCC Stylize

BCC Color & Tone

BCC Color & Tone

BCC Obsolete

BCC Color & Tone

BCC Stylize

BCC Particles

Uncategorized

Uncategorized

Nested Subgroup

BCC Key & Blend

BCC Key & Blend

BCC Transitions

BCC Match Move

BCC Color & Tone

BCC Transitions

BCC Transitions

BCC Transitions

BCC Transitions

BCC Perspective

BCC Perspective

BCC Perspective

BCC Perspective

BCC Stylize

BCC Transitions

BCC Obsolete

BCC Obsolete

BCC Film Style

BCC Blur & Sharpen

BCC Warp

BCC Stylize

BCC Image Restoration

BCC Image Restoration

BCC Image Restoration

BCC Stylize

BCC Lights

Uncategorized

BCC Stylize

BCC 3D Objects

BCC 3D Objects

BCC 3D Objects

BCC Browser

BCC Film Style

BCC Transitions

BCC Film Style

BCC Perspective

BCC Blur & Sharpen

BCC Film Style

BCC Obsolete

BCC Obsolete

BCC Film Style

BCC Obsolete

BCC Obsolete

BCC Image Restoration

BCC Transitions

BCC Textures

BCC Blur & Sharpen

BCC Lights

BCC Lights

BCC Lights

BCC Obsolete

BCC Stylize

BCC Obsolete

Nested Subgroup

BCC Textures

BCC Transitions

BCC Stylize

BCC Art Looks

BCC Color & Tone

BCC Color & Tone

BCC Time

BCC Time

BCC Stylize

BCC Lights

BCC 3D Objects

BCC Obsolete

BCC Transitions

BCC Image Restoration

BCC Transitions

BCC Obsolete

BCC Lights

BCC Obsolete

BCC Transitions

BCC Transitions

BCC Transitions

BCC Transitions

BCC Blur & Sharpen

BCC Obsolete

BCC Color & Tone

BCC Lights

BCC Transitions

BCC Obsolete

BCC Lights

BCC Transitions

BCC Key & Blend

BCC Obsolete

BCC Lights

BCC Key & Blend

BCC Key & Blend

BCC Transitions

BCC Time

BCC Image Restoration

BCC Key & Blend

BCC Film Style

BCC Match Move

BCC Key & Blend

BCC Key & Blend

BCC Art Looks

BCC Stylize

BCC Textures

BCC Warp

BCC Stylize

BCC Blur & Sharpen

BCC Image Restoration

Nested Subgroup

Nested Subgroup

Nested Subgroup

Nested Subgroup

Nested Subgroup

Nested Subgroup

Nested Subgroup

Nested Subgroup

Nested Subgroup

BCC Stylize

BCC Transitions

BCC Transitions

BCC Color & Tone

BCC Obsolete

BCC Textures

BCC Image Restoration

BCC Time

BCC Image Restoration

BCC Particles

Uncategorized

Uncategorized

Uncategorized

Uncategorized

Uncategorized

BCC Perspective

BCC Perspective

BCC Particles

BCC Particles

BCC Particles

BCC Particles

BCC Art Looks

BCC Particles

Nested Subgroup

Nested Subgroup

BCC Image Restoration

Nested Subgroup

BCC Warp

BCC Art Looks

BCC Time

BCC Key & Blend

BCC Key & Blend

BCC Stylize

BCC Blur & Sharpen

BCC Key & Blend

BCC Stylize

BCC Stylize

BCC Blur & Sharpen

BCC Transitions

BCC Particles

BCC Textures

BCC Lights

BCC Transitions

BCC Lights

BCC Lights

BCC Lights

BCC Lights

BCC Lights

BCC Lights

BCC Lights

BCC Lights

BCC Transitions

BCC Image Restoration

BCC Image Restoration

BCC Textures

BCC Lights

BCC Transitions

BCC Transitions

BCC Warp

BCC Transitions

BCC Textures

BCC Obsolete

BCC Color & Tone

BCC Stylize

BCC Stylize

BCC Obsolete

BCC Image Restoration

BCC Particles

BCC Particles

BCC Perspective

BCC Transitions

BCC Blur & Sharpen

BCC Lights

BCC Art Looks

BCC Lights

BCC Obsolete

BCC Textures

BCC Textures

BCC Obsolete

BCC Transitions

BCC Time

BCC Transitions

BCC Art Looks

BCC Transitions

BCC Time

BCC 3D Objects

BCC Time

BCC Time

BCC Color & Tone

BCC Transitions

BCC Warp

BCC Warp

BCC Transitions

BCC Film Style

BCC Key & Blend

BCC 3D Objects

BCC Blur & Sharpen

BCC Image Restoration

Uncategorized

BCC VR

BCC VR

BCC VR

BCC VR

BCC VR

BCC Transitions

BCC Warp

BCC Textures

BCC Time

BCC Stylize

BCC Warp

BCC Color & Tone

BCC Film Style

BCC Transitions

BCC Warp

BCC Art Looks

BCC Transitions

BCC Warp

BCC Textures

BCC Particles

BCC Image Restoration

BCC Match Move

BCC Textures

BCC Textures

BCC Obsolete

BCC Obsolete

BCC Obsolete

BCC Blur & Sharpen

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Tutorial

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Tutorial

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Title Studio

Effect:
BCC 2D Particles
BCC 3 Way Color Grade
BCC 3D Extruded Image Shatter
BCC 3D Image Shatter
BCC AE Licensing
BCC AVX Licensing
BCC Alpha Pixel Noise
BCC Alpha Process
BCC Alpha Spotlight
BCC Apply Modes
BCC Artists Poster
BCC Beat Reactor
BCC Beat Reactor Integrated
BCC Beauty Studio
BCC Blobs Wipe
BCC Blur
BCC Blur Dissolve
BCC Boost Blend
BCC Brick
BCC Brightness-Contrast
BCC Broadcast Safe
BCC Bulge
BCC Bump Map
BCC Burnt Film
BCC Cartoon Look
BCC Cartooner
BCC Caustics
BCC Charcoal Sketch
BCC Checker Wipe
BCC Chroma Key
BCC Chroma Key Studio
BCC Cloth
BCC Clouds
BCC Color Balance
BCC Color Choker
BCC Color Correction
BCC Color Match
BCC Color Palette
BCC Colorize
BCC Colorize Glow
BCC Comet
BCC Common Controls
BCC Common Controls - Avid
BCC Compare Mode
BCC Composite
BCC Composite Choker
BCC Composite Dissolve
BCC Corner Pin
BCC Correct Selected Color
BCC Criss-Cross Wipe
BCC Cross Glitch
BCC Cross Melt
BCC Cross Zoom
BCC Cube
BCC Cylinder
BCC DVE
BCC DVE Basic
BCC Damaged TV
BCC Damaged TV Dissolve
BCC DeGrain
BCC DeNoise
BCC Deinterlace
BCC Directional Blur
BCC Displacement Map
BCC Drop Shadow
BCC Dropout Fixer
BCC Dust and Scratches
BCC Dv Fixer
BCC Edge Grunge
BCC Edge Lighting
BCC Effects List
BCC Emboss
BCC Extruded EPS
BCC Extruded Spline
BCC Extruded Text
BCC FAQ
BCC FX Browser
BCC Fast Film Glow
BCC Fast Film Glow Dissolve
BCC Fast Film Process
BCC Fast Flipper
BCC Fast Lens Blur
BCC Film Damage
BCC Film Glow
BCC Film Glow Dissolve
BCC Film Grain
BCC Film Process
BCC Fire
BCC Flicker Fixer
BCC Flutter Cut
BCC Fractal Noise
BCC Gaussian Blur
BCC Glare
BCC Glint
BCC Glitter
BCC Glow
BCC Glow Alpha Edges
BCC Glow Matte
BCC Gradient
BCC Granite
BCC Grid Wipe
BCC Grunge
BCC Halftone
BCC Hue-Sat-Lightness
BCC Invert Solarize
BCC Jitter
BCC Jitter Basic
BCC LED
BCC Laser Beam
BCC Layer Deformer
BCC Lens Blur
BCC Lens Blur Dissolve
BCC Lens Correction
BCC Lens Distortion Wipe
BCC Lens Flare
BCC Lens Flare 3D
BCC Lens Flare Advanced
BCC Lens Flare Dissolve
BCC Lens Flare Round
BCC Lens Flare Spiked
BCC Lens Flash
BCC Lens Shape
BCC Lens Transition
BCC Levels Gamma
BCC Light Leaks
BCC Light Leaks Dissolve
BCC Light Matte
BCC Light Sweep
BCC Light Wipe
BCC Light Wrap
BCC Light Zoom
BCC Lightning
BCC Linear Color Key
BCC Linear Luma Key
BCC Linear Wipe
BCC Looper
BCC Magic Sharp
BCC Make Alpha Key
BCC Match Grain
BCC Match Move
BCC Matte Choker
BCC Matte Cleanup
BCC Median
BCC Misalignment
BCC Mixed Colors
BCC Morph
BCC Mosaic
BCC Motion Blur
BCC Motion Key
BCC Motion Tracker
BCC Motion Tracker AE
BCC Motion Tracker Avid
BCC Motion Tracker FCP
BCC Motion Tracker Motion
BCC Motion Tracker PRM
BCC Motion Tracker Red
BCC Motion Tracker Resolve
BCC Motion Tracker Vegas
BCC Multi Shadow
BCC Multi Stretch Wipe
BCC Multi Stripe Wipe
BCC MultiTone Mix
BCC Noise Map
BCC Noise Map 2
BCC Noise Reduction
BCC Optical Flow
BCC Optical Stabilizer
BCC Organic Strands
BCC Overview in Adobe
BCC Overview in Avid
BCC Overview in FCP
BCC Overview in Resolve
BCC Overview in Sony Vegas
BCC Page Turn
BCC Pan And Zoom
BCC Particle Array 3D
BCC Particle Emitter 3D
BCC Particle Illusion
BCC Particle System
BCC Pencil Sketch
BCC Pin Art 3D
BCC Pinning Controls
BCC Pixel Chooser
BCC Pixel Fixer
BCC PixelChooser – Legacy
BCC Polar Displacement
BCC Posterize
BCC Posterize Time
BCC Preferences
BCC Premult
BCC Presets
BCC Primatte Studio
BCC Prism
BCC Pyramid Blur
BCC RGB Blend
BCC RGB Edges
BCC RGB Pixel Noise
BCC Radial Blur
BCC Radial Wipe
BCC Rain
BCC Rays
BCC Rays Cartoon
BCC Rays Dissolve
BCC Rays Puffy
BCC Rays Radiant Edges
BCC Rays Radiant Spotlight
BCC Rays Ring
BCC Rays Ripply
BCC Rays Streaky
BCC Rays Textured
BCC Rays Wedge
BCC Rectangular Wipe
BCC Reframer
BCC Remover
BCC Reptilian
BCC Reverse Spotlight
BCC Ribbon Wipe
BCC Rings Wipe
BCC Ripple
BCC Ripple Dissolve
BCC Rock
BCC Rough Glow
BCC Safe Colors
BCC Scanline
BCC Scatterize
BCC Sequencer
BCC Smooth Tone
BCC Snow
BCC Sparks
BCC Sphere
BCC Sphere Transition
BCC Spiral Blur
BCC Spotlight
BCC Spray Paint Noise
BCC Stage Light
BCC Star Matte
BCC Stars
BCC Steel Plate
BCC Super Blend
BCC Swish Pan
BCC Temporal Blur
BCC Textured Wipe
BCC Tile Mosaic
BCC Tile Wipe
BCC Time Displacement
BCC Title Studio
BCC Trails
BCC Trails Basic
BCC Tritone
BCC Tritone Dissolve
BCC Turbulence
BCC Twirl
BCC Twister
BCC Two Strip Color
BCC Two Way Key
BCC Type On Text
BCC Unsharp Mask
BCC UpRez
BCC User Guide
BCC VR Blur
BCC VR Flicker Fixer
BCC VR Insert
BCC VR Reorient
BCC VR Sharpen
BCC Vector Blur Dissolve
BCC Vector Displacement
BCC Veined Marble
BCC Velocity Remap
BCC Video Glitch
BCC Video Morph
BCC VideoScope
BCC Vignette
BCC Vignette Wipe
BCC Warp
BCC Water Color
BCC Water Waves Dissolve
BCC Wave
BCC Weave
BCC Wild Cards
BCC Wire Remover
BCC WitnessProtection
BCC Wood Grain
BCC Wooden Planks
BCC Z Space I
BCC Z Space II
BCC Z Space III
BCC Z-Blur
Removed Gradient Parameters
Title Studio - The Title Container Parameter Guide
Title Studio Basics
Title Studio: Animating an Object Using Keyframes
Title Studio: Creating A Fade Effect
Title Studio: Creating a Credit Roll
Title Studio: Creating a Credit Roll Part Two
Title Studio: Creating a Type on Effect with Title Containers
Title Studio: Image Processors
Title Studio: Image Processors - Blur Shaders
Title Studio: Image Processors - Glow Shaders
Title Studio: Image Processors - Gradient Shaders
Title Studio: Image Processors - Key Shaders
Title Studio: Image Processors - Light Rays
Title Studio: Image Processors - Light Sweep
Title Studio: Image Processors - Scan Lines
Title Studio: Image Processors - Spotlight
Title Studio: Image Processors - Wipe Shaders
Title Studio: Image Processors: Linear Ripple
Title Studio: Keyframe Palette
Title Studio: Scene Container Parameter Guide
Title Studio: The Animation Tab
Title Studio: The Camera Tab
Title Studio: The Composite Tab
Title Studio: The Container Position Tab
Title Studio: The History Palette
Title Studio: The Info Window
Title Studio: The Lights Tab
Title Studio: The Preferences Panel
Title Studio: The Project Settings Window
Title Studio: The Render Tab
Title Studio: The Text Tool
Title Studio: The Tools Window
Title Studio: The User Marks Window
Title Studio: Understanding Track Structure
Title Studio: Working With Deformers
Title Studio: Working With Image Processor Shaders
Title Studio: Working With Spline Media
Title Studio: Working with the Composite Window
Title Studio: Working with the Controls Window
Title Studio: Working with the Timeline Window

PRODUCT UPDATES & SPECIAL OFFERS

Join our email newsletter and keep up to date